Scheduled for March 27, 2026 at 4:45 AM – 5:06 AM
Affects
TG EMEA
Under maintenance from 4:45 AM to 5:06 AM
Completed
March 27, 2026 at 5:06 AMCompleted
March 27, 2026 at 5:06 AMMaintenance has completed successfully.
In progress
March 27, 2026 at 4:45 AMIn progress
March 27, 2026 at 4:45 AMMaintenance is now in progress
Planned
March 27, 2026 at 4:45 AMPlanned
March 27, 2026 at 4:45 AMWe are planning for a scheduled maintenance during that time.