Scheduled for May 28, 2026 at 1:15 PM – 1:18 PMUTC
Affects
TG EMEA
Under maintenance from 1:15 PM to 1:18 PM
Updates
Completed
May 28, 2026 at 1:18 PMUTC
Completed
May 28, 2026 at 1:18 PMUTC
Maintenance has completed successfully.
In progress
May 28, 2026 at 1:15 PMUTC
In progress
May 28, 2026 at 1:15 PMUTC
Maintenance is now in progress
Planned
May 28, 2026 at 1:15 PMUTC
Planned
May 28, 2026 at 1:15 PMUTC
We are planning for a scheduled maintenance during that time. This is to address the missing map selector and icon when clicking on a point on the map.