Telematics Guru - TG Global - Geofences not showing in reports – Incident details

TG Global - Geofences not showing in reports

Resolved
Degraded performance
Started 2 months agoLasted 2 days

Affected

TG AMER

Degraded performance from 4:00 AM to 9:26 AM

TG APAC

Degraded performance from 4:00 AM to 5:08 PM, Operational from 5:08 PM to 9:26 AM

TG EMEA

Degraded performance from 4:00 AM to 9:26 AM

Updates
  • Resolved
    Resolved

    The fixes have been deployed across all regions. This incident has been resolved.

  • Update
    Update

    We have implemented a fix on the APAC region, and will continue to monitor.
    EMEA and AMER is scheduled to be fixed on the 08/10/2025

  • Update
    Update

    We have identified the root cause of the issue, and are busy working on a solution to ship out as soon as possible.
    Thank you for your patience while we work to get this resolved.

  • Identified
    Identified

    The incident is two-fold. Primarily the GeoFences are not being shown in reports, and a seemingly related issue with existing Trips not having their Geofences updated.

    We have isolated the cause of the issue, and are continuing to work on a fix.